Page 1 of 82 1231151 ... LastLast
Results 1 to 10 of 816
  1. #1

    [FREE] On-Spawn Loadout Enforcer for Infantry/Vehicles - AdKatsLRT [2.0.7.6]



    The Loadout Enforcer is now
    FREE

    This is the next level auto-admin, it acts On-Spawn, stopping usage of restricted weapons/gadgets/non-lethals/vehicle items before they become an issue. It can restrict attachments on weapons, like bipods and flashlights, or items other auto-admins can't detect at all, like smoke/flares. Vehicle weapons and upgrades can be restricted as well.

    All 3,500 infantry/vehicle weapons and equipment items in the game can be controlled, with customizable messages for each item. Settings allow for enforcement of problem players only, or all players, with per-item gradation of that severity.

    REQUIREMENTS: No Requirements.
    This plugin does NOT require the AdKats base plugin. They are designed to work together but are not required to, using it with the base plugin just unlocks more advanced features.



    • Normal
      • Enforce every infantry item (any primary, secondary, attachments, gadgets, knifes, and grenades) in the game, on-spawn.
      • Enforce every vehicle item (primaries, secondaries, countermeasures, optics, and gunner options) in the game, on-spawn, or on kill with specific vehicles.
      • Map/Mode specific enforcement options for mixed-mode servers are available.
      • Any update made to the game's weapons are automatically imported and made available, so if DICE changes or adds weapons, they are immediately enforceable.
      • Players notified and thanked when they fix their loadouts after being killed.
      • Customizable kill messages for each denied item, with combined messages and details if more than one is spawned in the same loadout.
      • Statistics on enforcement, including percent of players enforced, percent killed for enforcement, percent who fixed their loadouts after kill, and percent who quit the server without fixing their loadouts after kill.

    • Advanced Features With AdKats
      • Two levels of enforcement, allowing multiple levels of severity for each item.
      • In-game admin command to call more strict loadout enforcement on specific players.
      • In-game admin command to fetch and display a specific player's loadout.
      • Using the reputation system, reputable players are optionally not forced to change their loadouts, as we assume they are not going to use restricted items.
      • Admins are optionally whitelisted from spawn enforcement, but still fall under trigger enforcement if marked or punished.
      • Other plugins can call loadout checks and enforcement, so it can enhance your current auto-admin.


    All 3500 items in the game:






    This is a battlelog intensive plugin, so do not run it on more than one battlefield server from the same Procon layer IP address. If you have multiple servers to enforce, you must run the plugin from different PRoCon layer IP addresses. If you do not heed this warning, your layers run the risk of being temporarily IP banned from battlelog.

    Install: (Read the installation instructions below)







    Last edited by ColColonCleaner; 05-11-2016 at 05:28.
    ____

  2. #2
    Hi,

    i get some weird results on one of my servers, i have disabled Snipers/DMR, and when we spawn i get yells that i have to remove all snipers/DMR from loadout.

    [16:59:14] AdKatsLRT > Say > PlayerName > [join] [NBFC]PlayerName please remove [SRR 61] from your loadout.
    [16:59:14] AdKatsLRT > Tell[5s] > PlayerName > (1/12) Please respawn without RFB in your loadout
    [16:59:16] AdKatsLRT > Tell[5s] > PlayerName > (2/12) Please respawn without L96A1 in your loadout
    [16:59:18] AdKatsLRT > Tell[5s] > PlayerName > (3/12) Please respawn without GOL MAGNUM in your loadout
    [16:59:20] AdKatsLRT > Tell[5s] > PlayerName > (4/12) Please respawn without JNG 90 in your loadout
    [16:59:22] AdKatsLRT > Tell[5s] > PlayerName > (5/12) Please respawn without M40A5 in your loadout
    [16:59:24] AdKatsLRT > Tell[5s] > PlayerName > (6/12) Please respawn without M98B in your loadout
    [16:59:26] AdKatsLRT > Tell[5s] > PlayerName > (7/12) Please respawn without SCOUT ELITE in your loadout
    [16:59:29] AdKatsLRT > Tell[5s] > PlayerName > (8/12) Please respawn without SR338 in your loadout
    [16:59:31] AdKatsLRT > Tell[5s] > PlayerName > (9/12) Please respawn without SRR 61 in your loadout
    [16:59:33] AdKatsLRT > Tell[5s] > PlayerName > (10/12) Please respawn without SV 98 in your loadout
    [16:59:35] AdKatsLRT > Tell[5s] > PlayerName > (11/12) Please respawn without FY JS in your loadout
    [16:59:37] AdKatsLRT > Tell[5s] > PlayerName > (12/12) Please respawn without CS5 in your loadout

  3. #3
    Quote Originally Posted by TMiland View Post
    Hi,

    i get some weird results on one of my servers, i have disabled Snipers/DMR, and when we spawn i get yells that i have to remove all snipers/DMR from loadout.
    That message display issue was injected last night with the vehicle updates, fixed in 2.0.0.1.
    ____

  4. #4
    Quote Originally Posted by ColColonCleaner View Post
    That message display issue was injected last night with the vehicle updates, fixed in 2.0.0.1.
    Okay, i'll update asap!

  5. #5
    Senior Member
    Join Date
    Oct 2012
    Location
    FRANCE
    Posts
    146
    I just put a days the procon indicates only the version 2.0.0.0

    [Imgur](http://i.imgur.com/nNcJbQK.png)
    Last edited by virusdead; 22-01-2015 at 17:21.

  6. #6
    Quote Originally Posted by virusdead View Post
    I just put a days the procon indicates only the version 2.0.0.0

    [Imgur](http://i.imgur.com/nNcJbQK.png)
    You are running 2.0.0.1:


    If you reboot a procon layer without rebooting your procon client it doesn't show updated plugin version numbers. Just reboot your procon client and you'll see the updated version number.
    ____

  7. #7
    Senior Member
    Join Date
    Oct 2012
    Location
    FRANCE
    Posts
    146
    Quote Originally Posted by ColColonCleaner View Post
    You are running 2.0.0.1:


    If you reboot a procon layer without rebooting your procon client it doesn't show updated plugin version numbers. Just reboot your procon client and you'll see the updated version number.
    This is perfect thanks for your help beings

  8. #8
    A couple messaging updates in 2.0.0.2.
    ____

  9. #9
    Back to $25? Is that an early-adopter discount or the final price?
    Don't send me private messages (PMs) unless you really need privacy, like your game server password. If you just have a question or need help, post in one of the threads. It's extra work for me to answer questions and give help in private messages and no one else gets the benefit of the answer.

  10. #10
    The one and only Bassyboy
    Join Date
    Jul 2010
    Location
    Netherlands
    Posts
    3,274
    Any chance you will be adding settings per map or 'only enable on certain maps' to this plugin?

    I might be interested using it, but since I run ALL CQ maps I don't want to force the loadout on other maps than Metro / Lockers.

    I just want to reduce the explosive, flashbang and flare spam on those two maps, don't care about the loadout on other maps.

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •