Results 1 to 7 of 7
  1. #1

    vars.roundTimeLimit not working?

    I'm running a 32-player mixed mode (rush/obliteration) server and even though vars.roundTimeLimit is set, it's not properly functioning. There is no round timer. Is it maybe because of mixed mode or is this a known server bug?

  2. #2
    I don't know, but I had assumed that setting was for Obliteration mode only.
    Don't send me private messages (PMs) unless you really need privacy, like your game server password. If you just have a question or need help, post in one of the threads. It's extra work for me to answer questions and give help in private messages and no one else gets the benefit of the answer.

  3. #3
    Plugin Developer
    Join Date
    Oct 2010
    Location
    California
    Posts
    785
    vars.roundTimeLimit is working just fine. On obliteration, if set for 100, it puts up a 30 minute time limit. For Rush, I believe it sets an 8 minute timer per stage but I just have it disabled (set to 0) for when Rush maps come up on my server. I'm not sure of the time limits it gives TDM, Conquest, and the other modes when set to 100.

  4. #4
    I can't see it in the latest procon update, do we still need to set it manually in startup.txt I guess?

  5. #5
    TimSad:I've tried using your Ticket Time Setter plugin you wrote (0.1.5.0) and it doesn't seem to be setting it for Obliteration... Does the plugin log anything when it makes a setting change?

  6. #6
    Plugin Developer
    Join Date
    Oct 2010
    Location
    California
    Posts
    785
    It should work just fine. If your server is just starting up and on an Obliteration round, then you'll have to have vars.roundTimeLimit defined in your Startup.txt. Remember! - vars.roundTimeLimit set to 0 means there is no time limit and with it set to 100 it means 30 minutes on Obliteration.

  7. #7
    Procon 2 Alpha Test Group - Senior Leader Tester - Alpha Division
    Join Date
    Oct 2011
    Location
    Canberra, Australia
    Posts
    199
    Quote Originally Posted by Kinsman View Post
    I can't see it in the latest procon update, do we still need to set it manually in startup.txt I guess?
    https://github.com/Myrcon/Procon-1/c...5e11bef1bb1eba

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •