Page 1 of 12 12311 ... LastLast
Results 1 to 10 of 114
  1. #1

    Battlefield Admin Control Panel for AdKats [BFACP]

    Readme for version 2.0.3. Download

    Readme for version 2.1-dev. Download

    Further instructions for version 2.1-dev. Make sure to run the setup.sql script if you are not installing through the command line. Previous versions should not be in the database if you have to manually run the setup.sql script as it will throw an error when it tries to create the tables.

    Topic placeholder for version 3.0. I'll update this post when version 3 is released. For now support can be placed here instead of spamming the AdKats thread.
    Last edited by Prophet731; 03-12-2017 at 11:45. Reason: Added further instructions for version 2.1-dev
    Developer of the BFAdminCP

  2. #2
    We're using AdminCP 2.0.1 (newer version until 2.0.3 didn't work yet and I had no time to try 2.1).
    I got an issue on my scoreboard: I can't see my playerslist.
    Chat and everything else is there but no playerlist.
    This is since a few days and I couldn't fix it.
    In my errolog this message appears:
    "production.ERROR: exception 'ErrorException' with message 'Undefined offset: 10' in BFAdminBF3/app/bfacp/Libraries/BF3Conn.php:2709"
    I had a look into this file and line and there is:
    "$nRows = $res[10];"
    I can remember that there was kinda bug after the last BF3 server update but I can't remember if it was this line or another.
    Maybe someone knows a solution.

  3. #3
    Quote Originally Posted by Checka_Wiemi View Post
    We're using AdminCP 2.0.1 (newer version until 2.0.3 didn't work yet and I had no time to try 2.1).
    I got an issue on my scoreboard: I can't see my playerslist.
    Chat and everything else is there but no playerlist.
    This is since a few days and I couldn't fix it.
    In my errolog this message appears:
    "production.ERROR: exception 'ErrorException' with message 'Undefined offset: 10' in BFAdminBF3/app/bfacp/Libraries/BF3Conn.php:2709"
    I had a look into this file and line and there is:
    "$nRows = $res[10];"
    I can remember that there was kinda bug after the last BF3 server update but I can't remember if it was this line or another.
    Maybe someone knows a solution.
    Yes that has been fixed. Just save this file and upload it back to the folder and it should fix the problem.

    https://github.com/AdKats/BFACP/blob...es/BF3Conn.php
    Developer of the BFAdminCP

  4. #4
    Yeah I already solved this problem by changing in line 2709 the "10" into a "9" and everything was fine.
    But I wonder why this happened now?
    Thanks for the help Prophet :-)

  5. #5
    I just tried to install the version 2.1 on a clean system (didn't want to update my current adminCP).
    So I've uploaded all files and edited the .env.php (see picture here: https://abload.de/img/admincpv2.1_env2po16.jpg ).
    Now I've tried to open the subdomain for the adminCP and I get the following error: https://abload.de/img/admincpv2.1_fatalerrohnpvx.jpg

    Does anyone got a clue?
    Last edited by Checka_Wiemi; 28-11-2017 at 12:06.

  6. #6
    Quote Originally Posted by Checka_Wiemi View Post
    I just tried to install the version 2.1 on a clean system (didn't want to update my current adminCP).
    So I've uploaded all files and edited the .env.php (see picture here: https://abload.de/img/admincpv2.1_env2po16.jpg ).
    Now I've tried to open the subdomain for the adminCP and I get the following error: https://abload.de/img/admincpv2.1_fatalerrohnpvx.jpg

    Does anyone got a clue?
    What it looks likes is that the APP_KEY is not being registered on boot which would cause that error. Make sure the file on the server has those changes. Also running this version does make some database changes to the bfacp tables if you were on the latest non-dev version. So make sure you have a backup of the tables just in case.

    Sent from my ONEPLUS A3000 using Tapatalk
    Developer of the BFAdminCP

  7. #7
    Quote Originally Posted by Prophet731 View Post
    What it looks likes is that the APP_KEY is not being registered on boot which would cause that error. Make sure the file on the server has those changes. Also running this version does make some database changes to the bfacp tables if you were on the latest non-dev version. So make sure you have a backup of the tables just in case.
    Yeah I also thought about that issue with the key but I've take the key from another db (where version 2.0.1 is running) and this key is also 32 characters long and I just changed some letters in the new one (didn't change the length).
    I also took a new database to test this version.
    Didn't want to fuck up my old database ;-)

    But as I already said: the key is okay in my oppinion but I don't know why he won't start the side?
    I've also tried several 16, 24 and 32 characters keys but none worked.
    Last edited by Checka_Wiemi; 28-11-2017 at 15:18.

  8. #8
    Hi.In my Console, Procon shows this error:17:25:49 90] [AdKats] WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61
    Which version is the latest:2.0.3 or 2.1?
    Last edited by keb2; 28-11-2017 at 18:31.

  9. #9
    Quote Originally Posted by keb2 View Post
    Hi.In my Console, Procon shows this error:17:25:49 90] [AdKats] WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61
    Which version is the latest:2.0.3 or 2.1?
    Wrong thread.
    Ask it in this one: https://forum.myrcon.com/showthread....ghlight=adkats

  10. #10
    Quote Originally Posted by Checka_Wiemi View Post
    I wrote the message in the correct subject.This error comes from BFACP

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •