Results 1 to 3 of 3
  1. #1

    Plugin settings string array issue

    Guys,

    I'm having an issue with the plugin settings variables when I try to use string arrays for the variable. Procon is not saving the state of the variable upon restart. It does save the state of other types of variables such as boolean, int, etc.

    I'm loading a list using .ToArray() into the variable. It displays fine and I can edit it fine. The change occurs and it is even saved to the .CFG file for my plugin.

    However when I restart procon the default variable information from the plugin constructor is loaded back into the setting in the plugin settings tab and my changes are lost.

    As a test, I even copied over a setting from another person's plugin verbatim and I'm having the same issues. The state of the variable is saved in the .CFG file but Procon is not using this saved state. It is reloading the variable from the constructor in the plugin.

    Any idea what could be causing this? This is very aggravating. Hope you guys ran across this before.


    EDIT:

    NEVERMIND. I figured out what the problem was.
    Last edited by s1ngular1ty; 31-08-2015 at 07:22.

  2. #2
    Super Moderator
    Join Date
    Jul 2010
    Location
    Very North Darwin
    Posts
    1,550
    Self server customer

  3. #3
    The one and only Bassyboy
    Join Date
    Jul 2010
    Location
    Netherlands
    Posts
    3,261
    Care to share the issue & fix, so other plugin developers who encounter the same issue can find it here?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •